Image-Pro Plus

Find popular troubleshooting
and how-to resources

Image-Pro Plus

Get Started
Get Started

Install. Setup.
Get Started.

Latest major version

VERSION 7.0.1

Available to all customers with v7.0 and above

Frequently Asked Questions

Your Product Serial Number is printed directly on your Hardware Protection Key and can also be found on the ‘About’ dialog box. This can be launched by selecting “About <Product Name>” from the Help Menu from inside of the product.

Create your AOI on the first frame of your sequence.
Go to Process...Operations.
Your Sequence will be listed as the "First Operand".
Select "Add" as the operation.
The "Second Operand" should be "Number" and set "0" as the number.
For "Put result in", select "New Image".
When you hit "Apply" your new sequence will be generated.

Auto-threshold (Count/Size) is an iterative method. It assumes that the gray level histogram is the sum of two normal intensity distributions (two classes): Object pixels and background pixels. The threshold is usually not obvious because the two distributions overlap. The trick is to find where the two distributions intersect (By the way, even when the histogram has a clear valley, the threshold is not necessarily at the bottom of that valley).

For each gray level (t) along the histogram (h(t)), the algorithm calculates the variance of the two portions of the histogram lying on each side of t (v1(t) and v2(t)). It picks the gray level (threshold) that minimizes the sum of the two normalized variances. This variance is sometimes called the "within-class" variance, and can be expressed as:

vw(t) = s1(t)*v1(t)/S + s2(t)*v2(t)/S

where:

s1(t) = Sum(h(i), i=1->t),

s2(t) = Sum(h(i), i=t+1->n),

S = Sum(h(i), i = 1->n),

n = size of histogram.

In practice, instead of minimizing vw(t), the algorithm maximizes the "between-class" variance. It's faster, more complicated to explain, but it's the same exact thing.

Once you have set your intensity range selection in Count/Size, go to Count/Size|Select Measurements menu and select the PerArea measurement parameter. Press the "OK" button to accept and then press the Count button to count the objects. Open the statistics table by selecting the View|Statistics menu and observe the row called "Sum" in the table. In the column called PerArea and the row Sum, if found a decimal number. This decimal number multiplied by 100 gives the percent area of objects in you image. By creating any AOI (Area of Interest) and then following the same procedure as above, this will give the area% of objects WITHIN the AOI.

Before working with the data sheet, you should take a moment to review the display to make sure you are satisfied with the objects that have been extracted — you may want to eliminate extraneous objects, separate clusters that have been counted as a single object, or combine separate outlines into one. On the Count/Size: Edit Count/Size Edit Menu menu, Image-Pro gives you a number of tools that let you edit and finalize your count.

  • Draw/Merge Objects: This option lets you manually outline an object that was not included in the count, or combine two objects so that they are counted as one.

    To manually include an outline, select Draw/Merge then draw a polygon that traces the object, using any of the standard AOI tools: rectangular, elliptical or freeform (you can even use the Freeform tool's Auto Trace feature to automatically trace an edge.) When you have finished drawing the polygon, the specified measurements for that shape will also be added to the data sheet.

    Note - You can draw a polygon that defines an object that doesn't visibly exist in your image. This is usually done to define a region from which population density can be calculated.

    To combine two closely positioned objects into a single object, simply draw a narrow polygon that connects (not outlines) the two existing objects.

    Merging many objects in such a manner might be done to develop area outlines for population density analysis (see Population Density Analysis).

  • Split Objects: This option lets you manually divide clusters into single objects. Dividing is done drawing a division line between the objects you want to separate.

    After separation, the measurement data sheet will be updated to reflect the additional object, and the measurements of the original object will be adjusted to reflect the remaining object.

  • Auto Split: You can also use the Auto Split command to instruct Image-Pro to analyze all existing outlines and automatically split any clustered objects it finds. Of course, not all clustered objects can be separated with Auto Split; in general, circular objects with minimal overlap work best. Use the following criteria for determining whether your objects are clustered in a way that can be easily separated by the Auto Split operation:

    ¨ Individual objects within the cluster should be convex-shaped. An object is considered convex if all lines joining two points of the outline fall within the object.
    ¨ Objects should not overlap each other by more than 30%.
    ¨ The intersection of two overlapping objects should be identifiable by two concave points.
    ¨ Object outlines should be smooth enough to readily distinguish a concavity created by an overlap from a concavity that is simply part of the object.

    Note - Image-Pro splits objects with a straight line. It does not attempt to reconstruct the missing or hidden portions of an object.

    If the Auto Split command does not yield satisfactory results, try using the Watershed Split. This method does not rely on object concavities to determine lines of separation. Instead it erodes an object until it disappears, then dilates it back to its initial size, but does not allow it to touch its neighbors.

  • Watershed Split: Use the Watershed Split to automatically analyze every counted object and split clusters using the Watershed separation technique. The Watershed method erodes objects until they disappear, then dilates them again such that they do not touch.

    The Watershed Split command may be more effective than the Auto-Split method if your objects are not convex.

    You may remove an extraneous object from your count by using the Toggle Objects On/Off feature from the Count/Size : Edit menu. When an object is hidden, its outline and label are removed from the display and its measurements are eliminated from the data sheet. Deactivated measurements are also excluded from global statistic, classification and visualization operations. To permanently remove hidden objects, choose Delete Hidden Objects from the same Count/Size:Edit menu.

Measurement calibration is possible using reticules available from many Image-Pro dealers and microscope suppliers and well as companies such as Edmund Scientific and Fisher Scientific. Kodak has a variety of targets available for calibration of non-microscopic optical systems. For larger objects you should not neglect the possibility of imaging a set of accurate rulers, if they are flat enough to lie in the same optical plane as the objects.

There are many kinds of calibration standards available, including targets for calibrating angle, distance, intensity, linearity, and the spatial frequency response (Modulation Transfer Function or the Optical Transfer Function - MTF and OTF). The choice of which standard to use depends on what measurements you are making.

You should calibrate your measurements of importance both at the center of your imaging field and at the edges to ensure that your optical system is reasonably flat and undistorted. Total system precision is limited by the maximum of the smallest resolution of the system (how large is a pixel, how many gray scales can be distinguished), the limit of optical resolution, and optical distortions. System accuracy is limited by the sum of these resolution limitations and the base accuracy of your calibration standard as listed by the manufacturer. (Accuracy = adherence to an absolute standard, Precision = repeatability.)

A note about calibrating X and Y axis: No matter what optical system you use, as long as the image is digitized by a camera, a frame grabber, or a scanning device, you have to assume that the digitization process does not have a one-to-one aspect ratio. If that is the case, you will have to calibrate both X and Y axis. Image-Pro allows you to calibrate both axis, or to calibrate one axis and set the aspect ratio. Once calibrated, the program will give you correct spatial measurements regardless of the direction of measurement. Calibration and calibrated measurements are also covered extensively in Media Cybernetics software manuals.

With respect to spatial calibration, the aspect ratio reflects the relationship between the length of the vertical and horizontal axes in your image, and is expressed as X/Y. Aspect ratio is also calibrated using the Calibration command. If your camera's aspect ratio is not equal to your video card's aspect ratio, an image of a square object will not appear square when viewed on your display. To correct for this inconsistency, you can calibrate the aspect ratio from a reference square within an image.

Note - Camera/video card inconsistencies are not the only reason a square might not appear square on your display. It might simply be a misadjustment of your monitor's Vertical Size control.

Media Cybernetics partners with Velquest.
VelQuestis a leading supplier of Compliance Management Systems, which virtually eliminates tedious manual paperwork, while providing a common platform for data exchange. They offer extensive products and services, especially in the pharmaceutical industry, focusing on 21 CFR Part 11 compliance issues. Through strategic cooperation, Image-Pro Plus operates in conjunction with the VelQuestSmartShell Technical Remediation Solution.

Image-Pro has the ability to add a personal electronic signature to image and report files.

The Audit Trail is similar to the macro recorder, but trageted at keeping a log of everything that is done in Image Pro on a daliy basis. When enabled (Choose Edit|Preferences... and check Generate audit trail log.), the Audit trail feature creates a log of the equivalent macro call for every action you perform in Image Pro Plus. In addition, each line is prefeaced with the full time and date that the action was performed.

Below is a sample of the audit trail log:


2001/10/22 16:19:22.310 Image-Pro Plus logging started.
2001/10/22 16:19:23.570 ret = IpAcqShow(ACQ_SNAP, 0)
2001/10/22 16:19:30.710 ret = IpDocMove(0, 0)
2001/10/22 16:19:30.710 ret = IpAppSelectDoc(0)
2001/10/22 16:19:30.820 ret = IpDocSize(349, 288)
2001/10/22 16:19:30.820 ret = IpWsLoad("C:\IPWin45\Images\DemoGrn.TIF","tif")
2001/10/22 16:19:40.210 ret = IpDocMove(22, 22)
2001/10/22 16:19:40.210 ret = IpAppSelectDoc(1)
2001/10/22 16:19:40.210 ret = IpDocMove(6, 24)
2001/10/22 16:19:40.210 ret = IpDocSize(349, 288)
2001/10/22 16:19:40.210 ret = IpWsLoad("C:\IPWin45\Images\DemoBlue.TIF","tif")
2001/10/22 16:19:40.270 ret = IpDocMove(44, 44)
2001/10/22 16:19:40.270 ret = IpAppSelectDoc(2)
2001/10/22 16:19:40.270 ret = IpDocMove(12, 48)
2001/10/22 16:19:40.270 ret = IpDocSize(349, 288)
2001/10/22 16:19:40.270 ret = IpWsLoad("C:\IPWin45\Images\DemoRed.TIF","tif")
2001/10/22 16:19:56.970 ret = IpCmChannelMerge3(0, 2, 0, 1, CM_RGB, 1)
2001/10/22 16:19:57.020 ret = IpDocMove(66, 66)
2001/10/22 16:19:57.020 ret = IpAppSelectDoc(3)
2001/10/22 16:19:57.020 ret = IpDocMove(18, 72)
2001/10/22 16:19:57.020 ret = IpDocSize(349, 288)
2001/10/22 16:20:04.600 ret = IpCmpShow( COMP_SHOW )
2001/10/22 16:20:07.240 ret = IpCmpShow( COMP_HIDE )
2001/10/22 16:20:18.550 ret = IpCoLocShow(1)
2001/10/22 16:20:26.190 Image-Pro Plus logging ended.

This log file give you a per session record of what was done to an image, and can be used as a guide for reproducing your actions. You may also notice that by simply removing the date and time at the beginning of each line, and wrapping the resulting text with Sub Subname() and End Sub statements you can very quickly generate a macro to repeat exactly what you just did.

Many people have had troubles importing files with the .raw extension to Image-Pro Plus, since version 4.5.1 was released. This is because .raw is not a standardized format. Every software product and manufacturer that creates .raw files uses a different definition of the .raw format. Ours is based on the National Institutes of Health (NIH) .raw format. If this is causing a problem for you, you can disable the built-in .raw format and continue using the Flat File Descriptor that you have been using up until now.

This is done by adding a section to the IPWIN32.INI file. Use Notepad (Start|Programs|Accessories|Notepad) to edit this file add a section similar to the following:

[ReservedExts]
RAW=1

In the above example the offending NIH (RAW) format is removed - if you want to remove more formats, just add more lines in the ReservedExts section. What you want to use in each of these lines is the file extension for the format (e.g. PIC for BioRad).

Note: You MUST have Image-Pro Plus v4.5.1.25 or later for this feature to work.

One of Image-Pro's most powerful capabilities is its ability to let you perform spatial measurements upon your image, manually or automatically. There are two basic ways to perform measurements within Image-Pro:

  • Manually measuring single objects. Using the Measurements command in the Measure menu, you can measure the length of lines or polylines that you define, the area of polygons that you define, and the angles of arcs that you define. The Measurements command also lets you automatically trace and measure the edge of an object or feature in your image. You can measure distances between any two features, and perform tolerance testing using the new features of Image-Pro Plus Version 4.0.
  • Automatically counting and measuring multiple objects. Using the tools on the Measure menu, you can collect multiple measurements of multiple objects within a single image. If your objective is to count the number of cells in a sample, and measure the area, roundness or perimeter of these cells, this is the tool to use. Once the objects have been counted and measured, you can use the Count/Size window's Measure menu options to automatically sort and classify the objects by any of the measured characteristics. You can also visualize the classified data by plotting it on a scattergram, or pseudo-coloring the counted objects by class.
  • Manually counting and measuring multiple objects. Using the Manual Tag selection on the Measure menu, you can collect multiple measurements of multiple objects within a single image. You may select the number of objects in a class (up to 256) and the number of classes in a single image (up to 16), as well as the color, symbol, and name to identify each class.

Note - The counting and measuring operations will take advantage of your math co-processor if your system is so equipped. If you do not have a math co-processor, and plan to do a lot of work with counting and sizing, you may want to consider having one installed.

When a measurement is made, Image-Pro highlights the measuring outline and assigns a reference number. By default, Image-Pro displays its measurement outlines in yellow, and reference numbers in blue, but if you prefer other colors, you can assign them using the Options button in the Count/Size or Measurements window. Measurements remain on the screen until you close the image or explicitly delete the measurements using the Delete Measurements button.

When you have taken automatic measurements using the Count/Size command, the measurement values are recorded on a data sheet. You can view measurement information by simply double-clicking the measured object within the image.

You can view all current measurements by selecting the Measurement Data command on the Count/Size window's View menu. This will open the Measurement Data window, into which the data sheet for the active AOI or image will be displayed. Measurement data can be saved using the Data to File command on the Measurement Data window's File menu. Measurements are stored in ASCII form (*.CNT). The format for a measurement file is defined in Appendix B, File Format Specifications of the Image-Pro Reference Guide.

Measurement operations are performed in terms of image pixel positions, e.g., the length of a measurement is determined by the number of pixels along the line, the area of an outlined object is determined by the number of pixels within the outline, and so forth.

Note - When Image-Pro performs a measurement, the pixels included in the outline are included in the measurement. For example, when you are measuring the area of an object you have outlined, the pixels making up the outline are included in the area calculation.

Image-Pro's pixel-level measurements can be scaled to fit any coordinate system. This allows you to obtain measurements which are reported in terms meaningful to your application. For example, you can calibrate the measurement scale so that one pixel is equal to one foot, or so that five pixels are equal to one foot (or inch, or mile, or micron ). Fractional values are allowed. Image-Pro will express your measurements in terms of that unit. Additionally, if your image contains a measurable object of the unit length, you can calibrate your scale directly from that object, using the Image button in the Spatial Calibration dialog box.

Important - Calibrate your scale before taking your measurements. Once measurements are recorded, their values are not affected by a subsequent change in spatial calibration. For example, if after taking a line measurement of 50 pixels where 1 unit equals 1 pixel, you changed calibration to 1 unit equal to 10 pixels, the first measurement you recorded would remain at 50; Image-Pro will not automatically re-scale it to 5 to after the calibration is changed. You must take the measurement again in order for the new calibration to be reflected.

Once you have identified the measurements you want to take, you can set measurement criteria that will determine which objects Image-Pro includes in the count.

For example, you can instruct Image-Pro to include only objects larger than a certain size. This is done by establishing a valid range (i.e., specifying minimum and maximum values) for each measurement using the Set Ranges command in the Measure menu. If the object's measurement is within this range (min and max, inclusive), it will be included in the count. Objects with values outside the range are ignored.

Using the Count/Size command on the Measure menu you can count and measure multiple objects automatically. Once the objects have been counted and measured, you can use the Count/Size window's Measure menu to automatically classify them by any of the measured characteristics.
You can also visualize the data by plotting it using the Count/Size window's View menu options, or color the counted objects by class using the Auto Classification command on the Count/Size: Measure menu.

A new feature of Image-Pro Plus version 4.0 allows you to sort your counted objects according to area or other measurements. Use the Sort Objects selection on the Measure menu to generate a new image of your objects in sorted order.

The Saptial Calibrations dialog offers the ability to place a calibration marker on the image, which is useful for publication, since it easily documents the scale of objects in the image. However, many people find that the calibration marker is only partially visible (or completely invisible) after it is burned into the image.

This is because the calibration marker is burned in as a set of 1 pixel wide lines. One pixel wide lines are used because they eliminate the question of "where is the edge" when using them to calibrate the image again. The lines have not vanished, they have merely been hidden. With the increasing use of mega pixel digital cameras, many people's image are being automatically scaled down to 50% or even 25% of full size in order to display the entire are of the image on screen. Image-Pro reduces the size of an image on screen by only displaying every other row and every other column of pixels (for a 50% zoom). If the burned in calibration marker lines happen to fall on one of the hidden rows or columns, it will be hidden. These hidden lines will become visible if the image is zoomed to 100% or higher.


Helpful Resources

Videos Tutorial

Show more >

Community Posts

Show more >

Helpful Resources

Camera Support

Show more >

Microscopy Hardware Support

Show more >
Sign Up for software tips, webinars, publications and more