• Frequently Asked Questions - Autoquant

    FAQs - Autoquant

    Find popular troubleshooting
    and how-to resources

    AUTOQUANT DECONVOLUTION

    FAQs

    To add a New Objective:

    1. In the Data Manager panel, middle section, click the Instrument tab (4th tab, microscope graphic)
    2. In the Objective Lens grid, Name row, type a name for the new lens configuration.
    3. Enter the NA, lens immersion RI, and magnification for this new configuration.
    4. Press "Add" next to Objective Lens Database

    The new objective should now be available in the dropdown list in the Summary tab in successive runs.

    To add a new Probe:

    1. In the Data Manager panel, middle section, click the Channels tab (3rd tab, filter wheel graphic)
    2. For the channel(s) that require(s) a new probe name to be added, type the name of the probe in the "Probe" column
    3. Enter the emission (not excitation) wavelength of the fluorophore in the “Em” column.
    4. Select a color in the Color column.
    5. Press "Apply"

    The new probe should now be available in the dropdown list in the Summary tab in successive runs.

    AutoQuant X does not have a facility to store custom cameras. In part, this is because the camera information included is only used to help determine pixel sizes. So if the correct camera does not appear, simply enter the CCD pixel size (in microns) into the camera dropdown box (it doesn't even need a name). Given that, the objective lens magnification, and camera zoom and bin factors, the pixel size in the image will be calculated.

    Drag files directly from the File Open dialog onto the AutoQuant X desktop. This functionality is available from any Windows Explorer windows as well. This works as long as you don’t need sequence detection.

    1. Go to File->Open.
    2. Single left click on a dataset to highlight it.
    3. In the top right of the dialog you will be asked to “Select a dataset”. Highlight the dataset you want.  If you want a complete stack and it consists of several numerically sequential files click on “Use Sequence Detection” in lower left corner of the dialog.
    4. Check the box that says “Use Multi-Channel Import”.
    5. Click on the down arrow to add this channel into the Dataset Channels area.
    6. Select a color for the channel.
    7. Repeat steps 2 through 6 for each additional channel.
    8. Change the name of the dataset being created under “Output Name” if desired.
    9. Click “Open”.

    See also “Getting Started with AutoQuant X”

    You always want to practice good imaging before deconvolving.  The better the raw image the better the deconvolved image will be. In most cases you can get more that 8 bits of gray levels from your confocal PMT or CCD. This would be useful to the deconvolution. You should not clip or rescale data prior to deconvolution.

    Once the data is read in it is converted to a 32bit floating point format prior to deconvolution. This is done no matter if the data is 8bit or 12bit. The memory usage and processing time is the same.

    The dynamic range of your image is increased in most cases because blurred intensities are put back where they came from. You have the option to save in 16bit integer or 32bit floating point format to ensure that the resulting image isn't clipped or rescaled.

    AutoQuant X currently does not have a server based license. This is something that we are looking into including in future versions. We use a USB dongle to secure the software. It is possible to install the software on multiple machines and moved the dongle from one to another as needed.

    Make sure that it is repeatable. Try running it with a small test dataset such as \Tutorial_Data\Widefield\Pollen.deb. Contact Technical Support for information about how to submit error reports.

    Free up disk space on your hard drive. Even though the AQI temp directory may be located on another drive your windows temp directory needs to have adequate space to do image display.

    Yes we have successfully been able to do so using Bootcamp. It runs in Parallels as well but is very slow.

    1. Type ftp://ftp.mediacy.com/incoming into your internet explorer address bar. Make sure to remove the default http:// first. You can also use an ftp client such as WS_FTP.
    2. If needed use anonymous as the username and your email address as the password.
    3. Zip all files together using a compression program such as WinZip. Name the file with your last name and first initial.
    4. Drag your zipped file into the ftp folder or upload it using your ftp client. The transfer process could take several minutes. For security you can write but not read from this folder. If you upload your file, close internet explorer or your ftp client and open it again you will not be able to access your data.
    5. Important: Email techsupport@mediacy.com or the technical support representative to inform us that you have placed data on our ftp site, the file name, an explanation of your problem and all image parameters used.

    The deconvolution in AutoQuant X yields the same output as in version 9. It is faster, more powerful, and easier to use. It takes advantage of improved computer hardware like multi processing, 2GB+ of memory and 64bit processors. It also loads and processes more than 3 channels of data and time series data seamlessly. X has a new user friendly interface, more suppoted file formats, built in sequence detector to create multi dimensional datasets and improved spherical aberration detection. AutoDeblur version 9 has a slightly different counting and tracking interface that has a few more tools than AutoQuant X. AutoQuant X’s counting and tracking is more user friendly.

    There are a few different ways:

    • In AutoQuant X go View->Copy Current View. This copies the projection or slice view to the windows clipboard and it can be pasted onto a Photoshop image.
    • In AutoQuant X go File->Save Current View. This saves an 8bit, 3 channel tiff that can be opened by Photoshop.
    • Go File->Save As and select 8bit as the Data Type in the bottom right corner of the dialog. Photoshop can read this stack.

    According to Photoshop v6 documentation it is supposed to read 16 bit images but it does not seem to work with 16 bit images generated with AutoQuant. It doesn’t support 12 bit images at all. Photoshop v7 should have added file format support but we have not tested this.

    First, check for an avaiable upgrade by going to Start->All Programs->AutoQuant->AutoQuant X->Check for Updates.

    We recommend setting the /3GB switch if it hasn’t already been done for your computer. This gives you access to the entire memory installed in your system. Here are step by step instructions on doing so:

    For XP

    1. Start->Control Panel
    2. Open System Icon
    3. Select Advanced Tab
    4. Select Settings button in Startup and Recovery group
    5. Select the Edit button to open boot.ini file
    6. Add /3GB to the list of options after Windows=”Microsoft Windows…”

    Here is a link to the Microsoft article that describes the process:
    http://www.microsoft.com/whdc/system/platform/server/PAE/PAEmem.mspx

    For Windows Vista, Windows 7, Widows 8

    Right-click on the Command Prompt icon in the Accessories program group of the Start Menu. Click Run as Administrator. At the command prompt, enter: bcdedit /set IncreaseIserVA 3072

    Restart the computer.

    If this does not solve your problem please take a screen shot of the error message and send it to us. This will help us better diagnose where the problem is occurring. Also include the image parameters you are entering for deconvolution (xyz spacing, RI, NA, wavelength, and microscope modality). The image spacings may be too large which creates an enormous PSF that brings the system to its knees.

    If purchased before 5/1/06 It will have an AutoQuant key chain attached to the back. If purchased after 5/1/06 it will have the following information printed on the dongle itself:

    AQI-X
    Windows XP
    S/N AQI-XXXX

    Make sure the user has access to the temp directory. This is used by AutoQuant X as scratch space to hold temporary files generated during processing. It is set by going to File->User Options. If running on a 64bit machine the user must be part of the Performance Log Users Group.

    The AutoQuant deconvolution algorithms are the result of more than fifteen years of development and many millions in research funding. This has helped include innovative approaches to iteration acceleration, noise suppression and a better image first guess to assist processing.

    If your computer is connected to the internet go to Start->All Programs->AutoQuant->AutoQuant X->Check for Updates. If the computer where AutoQuant X is installed is not connected to the internet contact Technical Support to obtain a patch.

    The menu configuration file has become corrupt. Delete the aqiPlatform.exe.config.xml found in the program directory. The default location for this is C:\Program Files\Media Cybernetics\AutoQuant X\

    Go to File->Open and navigate to the folder where the files that reside. Select one of the files. At the bottom of the dialog check “Use Sequence Detection”. A filename will appear at the bottom of the dialog with dropdown menus representing changing text in the sequence. Use the dropdowns to specify how to open the sequence. Press open.

    Images are automatically scaled for display when loaded into AutoQuant software. The dimmest intensity is displayed as black and the brightest is displayed as white. This maps the dynamic range of the image to that of the monitor. In most cases this will give a brighter image. The original data is not affected; this is only done for display.

    We can read .TIFF, raw data, Biorad .PIC, Windows .BMP, Bitplane Imaris3 .IMS, ImagePro .SEQ, Nikon .IDS, .ICS, Nikon jpeg2000 .ND, .ND2, Metamorph .STK, Scanalytics .IPLAB and .IPL, Leica .LEI, Zeiss .LSM, and Zeiss .ZVI, CZI, in a variety of bit depths, Olympus OIF/OIB .oif, .oib,

    For formats we don’t support it is usually possible to save or convert the data into a .TIFF file that can be read by AutoQuant.

    Many formats are based on TIFF. Try to load using that filter.

    Change the temp folder in AutoQuant to one that was not at risk of being access-limited by Windows 7. The steps are:

    1. In Windows Explorer, create a "Temp" folder on a large hard drive outside of any Windows system folder (in this case, D:\Temp)
    2. In AutoQuant X, go to File->User Options
    3. Set "TemporaryFileDirectory" to the newly created temp folder
    4. Click the checkmark
    5. Close and restart AutoQuant X.

    Set the parameters for the first image. Right click on that image in the batch list and select copy optics settings to copy the spacing, modality, na, ri, and wavelength. Select copy operational settings to copy the type of processing, iteration number, noise level etc. You can then select the other files in the batch using shift-click or ctrl-click and paste these settings.

    This is best done by taking a picture of a stage micrometer and calculating the um/pixel from that using a line length tool. Measure as many delineations as possible. Measure from leading edge to leading edge or trailing edge to trailing edge of the hashes. The line length tool should give the total number of pixels for the length of the line. Divide the number of microns on the micrometer by total number of pixels by the. XY spacing is entered into our software as micros per pixel.

    We have a quick tool called the spacing calculator that will give a good approximation of xy spacing. It requires you know the camera pixel spacing (available from the manufacturer), camera binning, objective magnification and any zoom factor from a correction collar. This tool is available from Deconvolution->Deconvolution Settings->Standard Settings->Calculate Spacing in AutoDeblur v9 or from the Dimensions tab in the Data Manager of AutoQuant X. It uses the following equation:

    Spacing = Camera pixel size x Camera bin factor / magnification / camera zoom

    In some modes of Neurolucida each stack is saved independently on your hard drive. It is possible to deconvolve these independently and then use Neurolucida to stitch them into one large image. This requires some tampering with the data file that links all of the stacks together. This is a less than trivial operation and will need a little more explanation from Neurolucida’s creators.

    You can limit the number of CPU intensive operations (deconvolution is one of them) by going to File->User Options and setting this to a number less than 4 (default is 4).

    A derived or theoretical PSF is one that is generated using a mathematical algorithm. It describes the inherit blur that the microscope introduces into an image. This PSF is noise free and unbiased at the beginning of a blind deconvolution. It is improved upon during each iteration. Though it perfectly describes the optics of the microscope, objective lenses are never perfect and the PSF must be adjusted slightly to give a better approximation of what is actually happening. This is best method for doing deconvolution.

    A derived PSF many times is one that is acquired by imaging a sub micron bead and saved. It can also be saved as the result of a deconvolution. For a blind deconvolution you can load a PSF (derived) and start from there. This may assist the deconvolution in converging to a result faster because there is already a better approximation of the PSF and may need less iterations. If the PSF changes due to a number of factors it may require more iterations to converge to a result similar to a blind deconvolution using a theoretical PSF.

    Any of AutoQuant's iterative algorithms will retain the intensity within your image enabling a quantitative result with significantly better localization of intensity than that which can be achieved through the analysis of non-deconvolved image data.

    In addition to the preservation of the quantitative integrity of the data, the blind deconvolution will produce a dramatic increase in the dynamic range of the intensities present in the data, which in turn corresponds to an improvement of signal to noise ratio, perceived contrast, and the susceptibility of the image data to segmentation schemes used during quantization.

    In 3D deconvolution you are typically working with a volume of data and a spatially invariant PSF such that it does not vary over the volume being processed. This is necessary because of the use of Fourier Transforms to efficiently calculate the convolutions required for processing. In blind deconvolution the PSF is also modified but it is still invariant over the volume being processed.

    The entire volume doesn’t have to be processed in one deconvolution operation. You can have the software subvolume the dataset into smaller chunks and have the blind deconvolution determine a different PSF for each subvolume, thus allowing some form of spatial variation over the image. The subvoluming can be in either the XY plane or in Z depending upon how your software is setup.

    Having a spatially varying PSF in Z may allow spherical aberrations to be compensated for. Subvoluming is an approximation to the true imaging model if you have a spatially varying PSF. There has been work done in spatially varying PSF deconvolution, often in 2D for astronomical imagery such as that from the Hubble. However, the computing requirements are significant even compared to current 3D deconvolution.

    Subvoluming is also beneficial when your dataset is larger than that which can be processed by your computer system, though you do need to be careful of any potential blending artifacts that may occur at the boundaries.

    It is not possible to obtain a perfect deconvolution of this type in any sample with depth, due principally to the spatial variance of the point spread function throughout the imaged volume.

    Typically, the nature of the improvement achieved using deconvolution is one where we move the image closer to the ideal. Such improvements are not trivial, and can do much to improve one’s ability to visualize and analyze the image content in either two or three dimensions. Nevertheless, the user who expects to see perfect images absent of any residual blur and spherical aberration may be disappointed. In these cases we recommend that as much be done at the point of sample preparation and imaging to ensure that conditions are as ideal as possible.

    Specifically, this means matching the refractive index of the immersion media and the mounting media and ensuring that imaging deeply into the sample is avoided; all this to avoid spherical aberration and spatial variance in the point spread function. These suggestions, while they may serve to ensure that the point spread function in retained in a close to ideal state, are of course, not practical in consideration of typical biological and technological constraints that affect the imaging process.

    The intention of the blind deconvolution algorithm is to introduce a degree of freedom which permits the point spread function to change in response to the true nature of the imaging conditions. While we cannot perfectly address the issue of spatial variance of the point spread function presently, we at least can offer a “best fit” response to the characteristic of the data, and believe that this approach will sustain the most accurate results of any approach for the widest range of data.

    When deconvolving confocal data we recommend that you perform a spherical aberration detection on the volume prior to deconvolving. Doing this will help you to determine the extent to which this aberration is present in your data, and modify the deconvolution settings to compensate for the effect on average throughout the volume.

    Valid spacings are determined by the recommended Nyquist sampling for the lens indicated. If the spacings are more than ten times larger or smaller than Nyquist then they are considered invalid. For example a 1.4 NA Oil lens should have a XY spacing of 0.1um and Z of 0.25um approximately. An XY spacing of 11um is considered invalid.

    Your Product Serial Number is printed directly on your Hardware Protection Key and can also be found on the ‘About’ dialog box. This can be launched by selecting “About <Product Name>” from the Help Menu from inside of the product.

    Sign Up for software tips, webinars, publications and more